SuperDuper DataCenter(-Tech) Blog

A deep dive into datacenter technologies like virtualization, automation, backup, and networking – bridging the gap between enterprise-grade solutions and practical implementations for SMBs and/or home labs.

Hacked by CoupDeGrace

Hacked by CoupDeGrace

Greetz:

Hmei7, BrokenPipe, SimSimi, L4663r666h05t, AntonKil, d3b~x, Index Php, Mdn_Newbie, Sultan Haikal, Brian Kamikaze

Hacked by CoupDeGrace

Hacked by CoupDeGrace

Greetz:

Hmei7, BrokenPipe, SimSimi, L4663r666h05t, AntonKil, d3b~x, Index Php, Mdn_Newbie, Sultan Haikal, Brian Kamikaze

Veeam 13 Part 4 – Adding an ESX or vCenter to VBR

Now that the infrastructure is ready, it’s time to add a backup source. That´s why the next logical step is adding an ESX or vCenter to VBR. Since my VMware homelab is currently undergoing major restructuring, I only have a single ESX server running a few VMs. We’re now backing these up regularly using Veeam Veeam VBR.

It doesn’t matter whether the source is a complete vCenter or just a single ESX server, the procedure is 100% the same.

Veeam 13 Part 3 – Add the Infrastructure Appliance to the VBR server.

In the third part we bring it all together. We add the Infrastructure Appliance to the VBR server. Then we set it up as a hardened repo, which will later on serve as our primary backup target.

In order to create the hardened repo in your VBR appliance, two steps need to be done. First, the newly installed server is added to VBR as a managed server. Then, the actual repository is created, and all properties such as concurrency and immutability are configured.

To do this, we first log in to the web interface of the VBR server.

Veeam 13 Part 2 – Install a Hardened Repo on an HPE Server

In the second part of the Veeam 13 series, I demonstrate how to install a hardened repo on an HPE server using the new infrastructure ISO file from Veeam. Since the system is intended to serve as the primary backup target, I naturally used a dedicated physical server rather than a VM.

Veeam 13 Part 1 – VBR appliance installation

This is the first post of a series that will guide you through in the installation and setup of Veeam 13.
Every good IT infrastructure also needs a good, multi-level backup system. As a vExpert, you not only get VMware by Broadcom licenses for your HomeLab, but you can also obtain an NFR license from Veeam with a one-year term and all features.

Most people are familiar with the 3-2-1 rule for backups, but Veeam now recommends an extended version, the 3-2-1-1-0 rule (https://www.veeam.com/blog/de/321-backup-rule.html).

I have decided to run through the whole thing with Veeam 13 and set up a corresponding environment in my home lab.
I have plans to do the following:

  • A virtual Veeam Backup & Replication Server (VBR) based on the new Linux appliance
  • A physical Veeam Hardened RepoServer to store local backups
  • S3-based cloud storage to store copies of the local backups.

This would fulfill the 3-2-1 rules. I will consider how to cover the additional 1-0 as I go along with the setup.

VCF – Bare metal Edges for a WLD – part 2

In the second part I show up the necessary steps to get the previously installed edge nodes up and running inside NSX manager.

VCF – Bare metal Edges for a WLD – part 1

When using Overlay networks within your NSX environment, you need at least two edge nodes. VMware´s preferred way of deployment is VMs, as it´s the easiest and most comfortable way of deployment and management.

To enhance network flow and ensure high data rates, I decided to have a look on bare metal edges.

This two-post series will show how to basic install and join them into a VCF NSX manager.

VCF – NSX VMs deployed and deleted, again and again

While rolling out a new Workload domain, the SDDC manager got stuck in a loop of deploying the NSX appliances and deleting them instantly after the deployment finished. The interesting thing was that one out of the three VMs got deployed and started without problems.

The cause of this could be found in the domainmanager logfile on the SDDC manager host

/var/log/vmware/vcf/domainmanager/domainmanager.log
Powering on VM: ***-nsx01a
[..] -
[..] - Task Completed
[..] - Error: Task failed on server: The host does not have sufficient memory resources to satisfy the reservation.
[..] - Deleting VM: ***-nsx01a
[..] - Warning:
[..] -  - The manifest is present but user flag causing to skip it
[..] - Completed with errors on host ***
[..] ERROR [vcf_dm,677263b484ddb203cdedfa721556dc85,fe4c] [c.v.v.c.f.p.n.a.DeployNsxtManagerAction,dm-exec-1]  Deployment of NSX Manager failed using OVF tool
[..] DEBUG [vcf_dm,677263b484ddb203cdedfa721556dc85,fe4c] [c.v.v.c.f.p.n.a.DeployNsxtManagerAction,dm-exec-1]  Found error message - [Error: Task failed on server: The host does not have sufficient memory resources to satisfy the reservation.]

The management domain was also used to run other “Management VMs”. It slightly ran out of “reservable memory”. As the NSX VMs get a memory resource reservation, only the first VM got enough resources for the reservation and could be powered up, but there wasn´t enough for the latter two.

After increasing the memory of the ESXi Hosts the deployment could be finished without any problems.

Automated Server OS installation with IPXE – part2

In the second part, we take a look at the PHP scripts that will generate the necessary files to boot our servers as well as how to get all the needed information and data to successfully install an ESXi Host.

For ease of understanding, I´ll start with a “fake database” PHP file.
As I can´t give the code for our database backend I´ve created this fake script to show the idea behind the whole thing.

Page 1 of 2

Powered by WordPress & Theme by Anders Norén